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Inhouse and Macroscopic characterizations of HoCrO3

C. M. N. Kumar, PhD Thesis (2012), K. Komędera  N. K. Chogondahalli Muniraju,  Acta Phys. Pol. A, 145 (2024)

X-ray powder diffraction

Crystal structure: 

Othorhombic, Pnma (Pbnm) #62 

Specific heat

DC magnetization

TN  ≈ 142 K

This corresponds to magnetic ions:

Cr3+ (spin only S = 3/2)

Ho3+ (strong spin–orbit, J=8)

From Curie-Weiss fit:

μeff = 11.01 ± 0.02 μB

Neutrons can tell us if both ions order 

simultaneously. The moment size and 

directions for each magnetic site in the lattice.



X-ray powder diffraction Neutron powder diffraction

X-ray vs. Neutron powder diffraction
HoCrO3

Orthorhombic space group: 

Pnma (Pbnm) #62 

Atom x y z

Cr (4a) 0.0000 0.0000 0.0000

Ho(4c) 0.43449 0.25000 0.00670

O1(4c) 0.53340 0.25000 0.58885

O2(8d) 0.19680 0.05420 0.30450

4

X-ray diffraction:

Lattice structure

Neutron diffraction:

Lattice + Magnetic



Measurement and data details

Instrument: Neutron powder diffractometer SPODI at FRM II 

research reactor, Garching, Germany

Wavelength: 1.5482 Å

Data files:

Data collected at 300 K: HCO_300K.dat

Data collected at 100 K: HCO_100K.dat (→ HCO_100K.m2p)

Data collected at 4 K: HCO_4K.dat

Crystal Information File for crystal structure:

HoCrO3_300K.cif

 

Mag2Pol version used: 7.2.2Orthorhombic structure: Pnma (No. 62)
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The main interface of Mag2Pol



Is the sample a good scatterer or an absorber?
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Aim for  30 – 70 % transmittance

Low transmittance (<20% ): 
Heavy absorption → distorted intensities, 

surface scattering, need strong absorption 

corrections

High transmittance (>90%): 

Weak scattering → poor S/N, long 

counting time, weak magnetic peaks



The main interface of Mag2Pol
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The main window of Mag2Pol - GUI

Running the Mag2Pol application, the main window  

‘Mag2Pol’ will open. By default, the interface may look 

slightly different. You can modify this under the menu 

‘View’

This window should remain open as long as any other 

Mag2Pol utility or window is running. The current 

version of Mag2Pol will not save the project 

automatically, so make sure to save any project before 

closing this window. 
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The main window of Mag2Pol - GUI

Some key plot elements that needs to be 

activated under settings for the purpose of 

this hands-on. (For purely aesthetic reasons)
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Menu items (icons) on the main window relevant for this tutorial

4
Bonds: Opens a new window that is used to modify the visuals of the 

structural model [active after loading the structure file, if it is not active even 

after loading the cif file, press Ctrl+U (on Windows) or Cmd+U (on Mac)].

Irreducible representations: Opens a new window that provides details of 

irreps and lets you select one or more irreps for the refinement of magnetic 

structure (active when at least one magnetic ion is defined)
5

Sample info: Opens a new window that provides details of, lattice and 

magnetic structures and the results of the last refinements.
6

Spacegroup tables: Opens a window on which you can select magnetic space 

group (Shubnikov group) instead of irreps, to refine the magnetic structure.
7

Fit: Opens the window where you can choose the data file, and instrument 

resolution file, and perform the refinements. 
8

Settings: Opens a new window that lets you modify a few important settings 

about GUI, a graphical rendering of plots and figures, and also the refinement 

procedure. 
9

1 Open: Load a structure file (cif) or an existing Mag2Pol project (xml).

2 Save as: Save as a new Mag2Pol project (as *.xml).

3 Save: Append the currently working project with the same name.

Manual: Opens Mag2Pol manual in pdf format. 10

1 2 4 5 6 8 10

97
3
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Refining high temperature NPD data, collected in paramagnetic phase
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Try to find a reported structure (Crystal Information File)

13

Search for the structure in multiple free and subscription-based 

sources. For example, COD or in the Materials Project 

database.

HoCrO3 is not available in COD but can be found in Materials 

Project (you can sign in by linking your Google, GitHub, and 

many more accounts, or sign up using your email account).

Download symmetrized CIF and save as:

HoCrO3_mp-756834.cif

https://next-gen.materialsproject.org/

1

2

Other free structure databases:

https://www.rruff.net/

https://www.crystallography.net/cod/search.php

https://next-gen.materialsproject.org/
https://next-gen.materialsproject.org/
https://next-gen.materialsproject.org/
https://www.rruff.net/
https://www.crystallography.net/cod/search.php
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HoCrO3_mp-756834.cif

Open the CIF file in VESTA and standardize (optional) 

Utilities→Standardization of Crystal Data…

File→ Export Data → HoCrO3_mp-756834_Standardized.cif



Step 1: Loading the structure or an existing project in Mag2Pol

15

1
The structure file (*.cif, *.mcif) or existing 

Mag2Pol project file (*.xml) can be loaded by 

clicking this icon or through the menu tree: 

File→Open

In this case:

HoCrO3_mp-756834_Standardized.cif

If the structure file is loaded properly, several sections in the main window are 

populated automatically.  



Step 1: Editing structure, plot it your way!
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Extended the cell (box) to show2

After making changes, press Ctrl+U (on 

Windows) or Cmd+U (on Mac) to append the 

structure on the screen.

4

Here, R and S change the radius of the atom 

and S length of the spin vector (just cosmetic, 

has no effect on the refinement)



Step 1: Editing structure - bond and the octahedra
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Left-click on the ‘bonds’ icon to open the 

‘Bonds and polyhedral’ editing window.
1

2 Create 1 set of bonds between Cr and O, 

which creates CrO6 octahedra. Use the drop-

down menu, values, and dials to create the 

desired crystal lattice view. The structure in 

the main window will be updated when you 

press ‘Apply’ in this window.



Step 2: Enter the refinement (Fit) window and load experimental data

Within the ‘Fit’ window, you can load the data, 

load the instrument resolution file, and perform 

Le Bail Profile fit or Rietveld refinement. 

To load the experimental data we need to open the ‘Fit’ window, by clicking on the icon as shown in the screenshot below (or the keyboard shortcut ‘Ctrl+F’).
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Load the experimental data collected at 300 K

The data can be loaded under the ‘Data’ tab of the ‘Fit’ window. Mag2Pol can accept three kinds of data sets. In this example, we will start with ‘Powder diffraction 

data’ of HoCrO3 collected at 300 K (Paramagnetic phase).  Follow the numerical order indicated below.

4

Select the data format 

‘x y Sigma (Ins 10)’

Click on ‘Load pattern’ and select the data file when prompted. In this case: 

HCO_300K.dat

You can load more than one pattern. For example, if you have collected data with 

different wavelengths, or want to refine XRD data collected at same temperature. 

Or even single crystal diffraction data (polarized unpolarized)

Activate ‘Refine nuclear structure’

1
We are under the ‘Data’ tab

19

2
3



Step 2b: Confirm all the atoms are loaded properly

Activate ‘Atoms’ tab: Check if all the atoms are loaded properly and the occupancies nominally 

follow the chemical formula. Do not select any of these parameters for refinement at this stage.

20



Step 2c: Edit source, instrument, and wavelength parameters

2

1

Activate ‘Patterns’ tab

Select neutron as the ‘Source’ 

21

Right-click on the text ‘Geometry’ 

and follow the menu items as shown 

in the screenshot below, to select the 

neutron facility, instrument, and the 

appropriate monochromator (which is 

used for the experiment).

In this case, it is Ge(551) was is used 

to select neutrons of wavelength 

1.5482  Å



Step 2d: Check the peak function and set an appropriate scale factor

Adjust the value of the ‘scale’ factor so that the intensities of the 

calculated pattern roughly match those of observed data. If the 

model is nearly similar and the wavelength choice is correct then 

peak positions of calculated patterns (red curve) should match 

the experimental data (black curve)

2

Peak profile function is automatically updated here. 

You can also manually select it if, for any reason, it 

is different. For example, the instrument is not in 

the list, and you manually entered the wavelength. 
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Step 2e: Select the region to exclude from the fit ‘Excluded region’

Toggle the ‘excluded regions’ ON

1

On the plot, [Left click + hold] 

and drag on the region that needs 

to be excluded. Grey area here.
2

If it is necessary to remove an 

excluded region, right-click on 

the (grey) excluded area, and it 

will be removed

3

4
Toggle the ‘excluded 

regions’ OFF
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Step 2f: Select the background type

Right-click on the text ‘Background’ 

and select ‘linear interpolation’1

For manual background 

selection, toggle this ON 

2

24



Step 2f: Select the background

Select an appropriate number of background points by 

first activating the background icon and then adding them 

by left-clicking on the baseline of the experimental data 

at several places. The number of points you need to 

select depends on the background shape.

Toggle it off after selecting all the 

background points

1

25

2



Activate the refinement of background

Right-click on the text ‘counts’ in the 

Background section and select 

‘check all counts’

1
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Le Bail fit

Right-click on the text ‘nuclear’ 

and select ‘Le Bail’ option1

27

Activate the refinement of:

2

Notice the large value of the goodness of fit 

(GOF). And the difference curve below.
3

a, b, c: Lattice parameters 

∆0, A constant shift added to all 

calculated Bragg angles:

Influenced by:
• mis-calibration of detector zero

• instrument alignment

4



Run Le Bail fit

Fit is already starting to look better; the difference 

curve is much smoother3

28

Activate ‘Fit’ tab 

Left-click on ‘Fit’. 

While the fit is running, this tab appears with the text ‘Stop’, 

if you see that the fit is diverging, stop the fitting by right-

clicking on ‘Stop’. 

2

Refined parameters window 5

If the fit diverges, you can left-click on ‘Undo’ to retrieve 

the parameters with which you started the last fit.4

1



Calculated diffraction intensity: Le Bail fit

29

Calculated diffraction intensity Le Bail:

Q = (hkl): reflection index

IQ : refined integrated intensity of each reflection (free parameter; no structure factor)

Φ(...): peak profile (U, V, W, X, Y, asymmetry, sample displacement, etc.

Bi: background intensity at point i (polynomial / point-interpolated / Debye-like), modeling all 

non-Bragg contributions.

2θQ: Bragg angle obtained from lattice parameters via 

   2*d*sinθQ ​= λ

In Le Bail fit, 𝐹𝑐𝑎𝑙,𝑄 is not computed from structure factors, 

instead, refined reflection intensities serve as effective 𝐹2

σᵢ = statistical counting uncertainty of each observed point.

m = number of observations (data points),

n = number of refined parameters

Least square  minimization via: Agreement is evaluated via:

Here Iobs,Q​ ≈ IQ​ after convergence



Refine more profile parameters

30

GOF has significantly improved from the 

previous step, already
2

Activate refinement of X and Y 

Influenced by:
• crystallite size (Lorentzian term)

• strain broadening (high-angle broadening)

• instrument axial divergence (partially)

X and Y control the Lorentzian 

component of peak width:

3

Activate ‘Patterns’ tab 1

4
Go to the ‘Fit’ tab and run the 

refinement by left-clicking on 

the ‘Fit’ button. Then return back 

to ‘Patterns’ tab. 



Refine more profile parameters

31

Further improvement in GOF2

Activate refinement of ∆X and ∆Y 

∆X: Sample height deviation

∆Y: lateral mis-positioning along the 

beam direction 

3

4
Go to the ‘Fit’ tab and run the 

refinement by left-clicking on 

the ‘Fit’ button. Then return back 

to ‘Patterns’ tab. 

Activate ‘Patterns’ tab 1



Refine more profile parameters

32

Further improvement in GOF2

Fix: Offsets, ∆X and ∆Y

3

5
Go to the ‘Fit’ tab and run the 

refinement by left-clicking on 

the ‘Fit’ button. Then return back 

to ‘Patterns’ tab. 

Activate ‘Patterns’ tab 1

Refine: u, v, w, which control 

the Gaussian component of the 

peak function 

4



Refine more profile parameters

33

Further improvement in GOF2

Refine: A₁, A₂ asymmetry correction 

coefficients describing peak tails on 

the low-angle side

3

4
Go to the ‘Fit’ tab and run the 

refinement by left-clicking on 

the ‘Fit’ button.

Activate ‘Patterns’ tab 1



Run final Le Bail fit

34

Activate ‘Fit’ tab 

Left-click on ‘Fit’. 2

Further improvement in GOF

3

Left-click on ‘Accept’ to accept 

the refined results thus far
4

1



Save a copy of the project file

35

Go to the main Mag2Pol window

Save a copy of the project as ‘HCO_300K_LeBail.xml’2

Go back to the ‘Fit’ window

3

1



Activate Rietveld refinement of lattice structure

36

Right-click on ‘nuclear’ under the 

‘Phase’ section and choose Rietveld.
3

Activate ‘Patterns’ tab 1

Fix Asymmetry parameters2

Activate the refinement of ‘scale’4Higher value of GOF 

(anywhere between 20-60)
5



Rietveld refinement of lattice structure

37

Right-click on x and ‘check all x’ to select 

symmetry allowed refinable x co-ordinates of 

all atoms. Repeat this for y and z co-

ordinates as well.

2

Activate ‘Atoms’ tab 1

Set B (Biso) isotropic thermal displacement parameter to be 

0.5 for all atoms (a good starting point). Do not refine them 

together with atomic positions, to start with.

3

4
Go to the ‘Fit’ tab and run the 

refinement by left-clicking on 

the ‘Fit’ button. Then return to 

the ‘Patterns’ tab. 
In some cases, starting the refinement of both positions 

and thermal parameters might lead to divergence or 

local minima, so refine positions (x, y, z) first and then 

activate and refine thermal parameters (B).   



Calculated diffraction intensity: Rietveld fit

38

σᵢ = statistical counting uncertainty of each observed point.

m = number of observations (data points),

n = number of refined parameters

Least square  minimization via: Agreement is evaluated via:

Calculated diffraction intensity Rietveld:

Q = (hkl): reflection index

mQ :  multiplicity

LQ : Lorentz factor

|F_cal,Q|² = |N(Q)|² + |M⊥(Q)|² – from nuclear + magnetic structure factors

Φ(...) – peak profile (U, V, W, X, Y, asymmetry, sample displacement, etc.

bi – background intensity at point i (polynomial / point-interpolated / Debye-like), 

modeling all non-Bragg contributions.

Nuclear structure factor:

Magnetic structure factor:

Only the perpendicular 

component scatters



Activate Rietveld refinement of lattice structure
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Activate ‘Patterns’ tab 1

Improved GOF2



Rietveld refinement of lattice structure

40

Activate all B (thermal parameters)

2

Activate ‘Atoms’ tab 1

3
Go to the ‘Fit’ tab and run the 

refinement by left-clicking on 

the ‘Fit’ button. Then return to 

the ‘Patterns’ tab. 



Rietveld refinement of lattice structure

41

Activate ‘Patterns’ tab 1

Much improved GOF. 

Visually satisfactory fit
2



Rietveld refinement of lattice structure

42

1 Set desired plotting range

Rearrange the plot window to a desired-

looking aspect ratio and font size 

2

Left-click the export icon, then 

select either PDF or ASCII.

3



Accept the final Rietveld refinement results

43

Activate ‘Fit’ tab 

Left-click on ‘Accept’ to accept the final refinement 

results and return to the main window
2

1

At any stage, if the fit diverges, you can recover previous states by pressing the ‘Undo’ 

button. It can go back as many steps as you want, all the way back to the initial state of the 

refinements of the current session.



Save a copy of the project file

44

Go to the main Mag2Pol window

Save a copy of the project as ‘HCO_300K_Lattice.xml’2

1



Export the structure graphic and cif

45

Use the menu File→Export→ Graphic to save the crystal structure exactly as seen on the main window.

Use the menu File→Export→ cif to save the crystal information file for publication of or to be plotted in external programs.1
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Refining low temperature NPD data, collected in the magnetically ordered phase



Save another copy of the project file

47

Save a copy of the project as ‘HCO_4K_Lattice.xml’

We will use the 300 K refinement project as the starting point for the refinement of 4 K data

Go to the ‘Fit’ window

1

1



Load the experimental data collected at 300 K

The data can be loaded/replaced under the ‘Data’ tab of the ‘Fit’ window. Mag2Pol can accept three kinds of data sets. In this example, we will start with ‘Powder 

diffraction data’ of CrSbSe3 collected at 300 K (Paramagnetic phase).  Follow the order indicated below.

Select the data format 

‘x y Sigma (Ins 10)’

Make sure ‘Refine nuclear structure’ is active

1
We are under the ‘Data’ tab

48

2

4

Right-click on the data file name and choose ‘Replace’. 

Select the file HCO_4K.dat when prompted.
3



Rietveld fit of Lattice only contribution to 4 K data

49

Refine

:::

Notice the large value of the GOF. And the 

difference curve, especially at a small 2Theta range.1

a, b, c: Lattice parameters 

Scale and lattice parameters (a, b, c)

4

2



Accept the Rietveld refinement results

50

Activate ‘Fit’ tab 

Left-click on ‘Accept’.3

1

Significant improvement in GOF.2

Close this window and 

return to the main window

4
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Save Rietveld fit of the Lattice only contribution to 4 K data

Left-click on the save icon1

We have refined only the lattice 

contribution so far, and now we can define 

the magnetic ion and proceed with the 

refinement of the magnetic structure.
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Refinement of magnetic structure

Session 3



Activate (define) magnetic ions

Under the ‘Atoms’ section:

Depending on the type of magnetic contribution, 

simply add the prefix M or J to the magnetic ion, 

followed by the ionic state. In this case, only Cr3+ and 

Ho3+ are magnetic.

After this, update the structure by the keyboard 

shortcut [Ctrl+U] (on Windows) or [Cmd+U] (on 

Mac) 

2
As soon as a Magnetic atom is defined under the 

‘Atoms’ section, the ‘Spins’ section will be populated 

automatically with the Magnetic ions. By default, the 

Propagation vector is set to (0, 0, 0). Leave 

everything default for now. We will determine 

magnetic propagation vectors soon.

1

3Open the fit window

53

Ion
Electronic

configuration
S L J Notes

Cr³⁺ 3d³ (t₂g³, ⁴A₂g) 3/2 ≈ 0 ≈ 3/2

3d ion; orbital moment 

quenched:

→ spin-only M

Ho³⁺ 4f¹⁰ (⁵I₈ term) 2 6 8
4f ion; strong spin–orbit:

→ total J form factor



Fix all the atomic parameters

1

At this stage, do not refine any of the atomic parameters. 

Fix them by unchecking one by one or by right-clicking 

on the column name and selecting ‘uncheck all’

54
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Determination of propagation vector

1

4 Zoom into the section of the diffraction pattern 

where you see magnetic peaks (at higher d-range)

2
Activate the ‘magnetic’ option by 

ticking this button. If this is not 

selected option (5) will not work.

Make sure the magnetic peak profile 

function is the same as the nuclear 

profile. If not by default, select it 

manually.

3

55



Determination of propagation vector

1
Click on the ‘satellites’ tab which 

will open a new window 

56

2 A ‘Satellites’ window pop open



Select satellite (magnetic) peaks and q-vector type

Left-click on the center position of each satellite peak (Peaks 

with excessive peak intensities in the difference curve)

Move this ‘Satellites’ window away from the ‘Fit’ 

window so that the diffraction profile is accessible. 
1

2

57

Each selected satellite peak will have a blue vertical 

column. The position of the blue vertical column can be 

altered using a mouse (left-click + hold + move) and can 

be removed by right-clicking on it

3

This is the list of satellite peaks 

that is automatically populated 

upon their selection on the ‘Fit’ 

window, in option (2)

Select an appropriate q-vector type 

expected based on the lattice symmetry. 

5

4



Select satellite (magnetic) peaks

58

Clicking on ‘Find q-vector’ 

will run the search routine. 

1

2
List of up to 20 best q-vectors that fit the 

selected satellites, populated automatically 

after running ‘Find q-vector’.

The q-vector highlighted in (2) will appear 

here. We can modify these values and see 

how calculated satellite peak positions 

change, live on (3).

In this case, q-vector is (0, 0, 0)

4The position indicated by Cyan columns here is the 

calculated peak position corresponding to the selected 

‘propagation vector’ on the ‘Satellites’ window [section 

indicated in option (2) on this slide].

3

Note down all the propagation vectors that you wish to 

try out (typically is the case for incommensurate 

structures)

5



Step 5c: Run the q-vector search, and note down the best q-vectors

Clicking on ‘Find q-vector’ 

will run the search routine. 

1

2
List of 20 best q-vectors that 

fit the selected satellites best, 

Populated automatically after 

running ‘Find q-vector’.

The best q-vector is listed here 

by default, after running ‘Find 

q-vector’. 

In this case it is (0, 0, 0)

3
The position indicated by Cyan columns here is the 

calculated peak position corresponding to the selected 

‘propagation vector’ on the ‘Satellites’ window [section 

indicated in option (2) on this slide].

4

Note down all the propagation vectors that you wish to 

try out. Close both the ‘Satellites’ and ‘Fit’ windows. 

And go back to the main window of Mag2Pol. 

5
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Refinement of magnetic structure using irreducible representations

Left-click on ‘irreducible representations’

2

In the newly opened ‘Irreducible 

representations’ window, the ‘Symmetry’ 

tab provides details of symmetry analysis 

and magnetic representation.

Pnma (No. 62)

For k = 0,

the little group = full space group

(all 8 symmetry operators)

Both Ho and Cr have 4 

positions per unit cell.

 

These orbits define how the 

spin components on each atom 

are linked by symmetry

Ho can order according to any of 

the 8 irreps, some with multiple 

independent basis vectors.

Cr can order only via Γ₁, Γ₃, Γ₅, Γ₇ 

(Γ₂, Γ₄, Γ₆, Γ₈ are not allowed for Cr).

If the propagation vector is other than (0,0,0), 

change it here. And update it by pressing the 

keyboard shortcut ‘Ctrl + U’ (Windows) or 

‘cmd + U’ (on Mac). In the current case, it is 

the default value. 1
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Refinement of magnetic structure using irreducible representations

Pnma (No. 62)

Practical refinement strategy

1. Choose irreps allowed for both Ho(4c) and Cr(4a)

Only Γ₁, Γ₃, Γ₅, Γ₇ appear in the Cr decomposition →

These are the only viable magnetic irreps for the whole structure.

2. Refine each candidate irrep

Load the basis vectors for Ho(4c) and Cr(4a) in Mag2Pol.

Refine the basis-vector amplitudes and compare fit quality.

3. Select the irrep that fits best

The irrep giving the best agreement with the magnetic Bragg intensities is 

the common irrep for both Ho and Cr.

4. (Later) Convert this irrep solution into the corresponding MSG to 

impose the same ordering via symmetry constraints.



On the ‘Irreducible representation’ window select an irrep (Γn) for the refinement

The ‘Symmetry’ tab provides details of 

symmetry analysis and magnetic representation

1

The ‘Basis vectors’ tab provides details of the 

Basis vectors of all magnetic sites for an irrep.

2Choose an irrep to see the Basis 

vector details for each magnetic ion 4

The ‘Irreps’ tab lists all irreps.

Right-click on one of the irreps symbols (Γ1 in 

this example), and consequently click on ‘Use Γ1’ 

Go back to the main window of Mag2Pol 

62
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Save the project with an appropriate name that indicates the irrep

Save as ‘HCO_4K_Mag-G1.xml’ 2

3
Right-click to open 

refinement window

Set a reasonable value for the coefficients of 

the allowed number of basis functions. And 

update it by pressing the keyboard shortcut 

‘Ctrl + U’ (Windows) or ‘cmd + U’ (on Mac).1



Fix all atomic parameters 

On the ‘Fit’ window, under the ‘Atoms’ tab, make 

sure all the atomic parameters are fixed. 1
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Activate refinement of magnetic moments 

Set the coefficient of the magnetic moment if not done in the 

previous step, and activate their refinements. 

Note here, symmetry constraints are already applied, so only 

allowed coefficients are active; others are inactive and can not be 

modified.

1

2
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Fix all parameters but the scale

Fix all parameters except the ‘scale’ 

parameter.

2

1

3

66

Also, make sure both ‘nuclear’ and 

‘magnetic’ phases are active 

Nuclear and magnetic phases should 

have the same Peak functions



Run the Rietveld fit

2

1

After accepting the refinement results on the 

‘Fit’ window (keep this window open), go to 

the main window and click on the save 

button, which appends the previously saved 

project, HCO_4K_Mag-G1.xml4

Once the convergence is reached, accept 

the fit results by clicking this button.

3

The fitting of magnetic peaks is rather poor with 

the irrep Γ1. We should test other irreps.5

67



The irrep 3 (Γ3) looks best and is applied to 

the model at the end of the test. At this stage, 

we can refine Cell and profile parameters and 

atomic parameters in steps, which can further 

improve the refinements.

Test all irreps by running built-in Fit macros

1 Select the macro ‘Test irreps’

Click on this arrow 

to run the macro
2

We can test each irrep one by one by selecting them in the main window of the Mag2Pol. But this can also 

be done much faster using the built-in fit macro ‘Test irreps’.

68

3

4
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Save the project with an appropriate name that indicates the new irrep used

Save as ‘HCO_4K_Mag-G7.xml’ 1

Click this to change the 

perspective of the structure
2

3 Back to the fit-window



In steps activate and refine all necessary parameters

70

Activate refinement of different 

parameters in steps. Run the fit during 

each step.

1. BG

2. Offsets and Asymmetry parameters

3. Profile parameters

4. Atomic positions

5. Thermal parameters (B)



Magnetic R-factor, RF,mag is a good 

indicator to pick the best irrep 

(along with the visual fit)

Final refinement results for irrep 3

1

2

71

3

Note that coefficients C1 and C3 are 

quite small and can be fixed to zero 

during the final refinements

After accepting the refinement results here, do not forget to save the project 

from the main window!

It is recommended to save versioned copies of the project often. If the 

program crashes, it is easy to start over from the saved versions.



Inspecting full refinement results

1

Click this icon to open the ‘Sample info’ window, which contains detailed information on the refined Crystal 

structure, Magnetic structure, and Fit results. Also indicates the path and name of the current project file.

2

‘Sample info’ window, with the 

‘Crystal Structure’ tab active.
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Inspecting full refinement results

73

1

‘Magnetic structure’ tab information of the 

magnetic model used in the last fit.



Inspecting full refinement results

74

1

The ‘Fit results’ tab contains detailed 

refinement results of the last fit. 



Refining magnetic structure using Shubnikov groups 

(Magnetic space groups)

75



Set up a Magnetic Space Group (MSG)

76

Click on the ‘Space group tables’ icon to 

open the new window with the same name.1



Set up a Magnetic Space Group

1 Activate the ‘Magnetic SGs’ tab

Type the notation of an appropriate Magnetic Space 

Group or select it from the drop-down menu.

For this example, let’s choose one of the first 

allowed magnetic space groups Pnma (62.441).

2
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Set up a Magnetic Space Group

1 Switch to the ‘Preview’ tab

78

Click on the button ‘Transfer MSG’3

2 Keep an eye on the magnetic structure in 

the main window

4 In the main window of the Mag2Pol, the space group is 

appended to Pnma_ (underscore indicates it is a MSG)

The spin arrangement in MSG Pnma_ (which is appended now on 

the main window) looks very different from the irrep 3 above

The MSG Pnma_ is not a suitable magnetic model 

5

1Reset symmetry



Set up a Magnetic Space Group

1 Activate the ‘Magnetic SGs’ tab

Try other MSGs within the Pnma setting of the parent.

But for the exercise, let’s now choose Pn’m’a (62.446).

2
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Set up a Magnetic Space Group

1 Switch to the ‘Preview’ tab

80

Click on the button ‘Transfer MSG’3

2 Keep an eye on the magnetic structure in 

the main window

4 In the main window of the Mag2Pol, the space group is 

appended to Pn’m’a

The spin arrangement in MSG Pn’m’a is identical to irrep 3. This 

could be actual MSG
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Save the project with MSG Pn’m’a

Save the project as ‘HCO_4K_Mag-Pn’m’a.xml’1 2
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Save the project with MSG Pn’m’a

Activate the refinements of all allowed basis vectors (BV)

1



1

2
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3

After accepting the refinement results here, do not forget to save the project from the main window!

Save the project with MSG Pn’m’a

The refinement results using the Magnetic 

Space Group Pn’m’a are identical to those 

obtained using irrep Γ3.
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Exporting the refined structures, parameters and patterns 



85

Export refined pattern as PDF or ASCII

While exporting it as a PDF rearrange the 

window to a desired aspect ratio. What you 

see is what you get.

2



Export the Graphic and structure models

The structure model can be 

exported as:

*.png (Graphic) 

*.cif

*.mcif

by following the menu tree:

File→Export→

86

2

1Plot tweaks



Step 7e: Export refinement results as latex tables

A variety of fit results can be copied 

directly in LaTeX format by following 

the menu tree:

Tools→LaTeX export

87

1



88

Exercise



89

Refine the lattice and magnetic structure of HoCrO3 at 100 K

Instrument: Neutron powder diffractometer SPODI at FRM II 

research reactor, Garching, Germany

Wavelength: 1.5482 Å

Data files:

Data collected at 100 K: HCO_100K.dat (→ HCO_100K.m2p)

Orthorhombic structure: Pnma (No. 62)

Hint: 

Only Cr3+ is magnetically ordered at this 

temperature
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• Our tutorial on the refinement of time-of-flight data is available on the website for the Tof Neutron 

Diffractometer POWGEN, Oak Ridge National Laboratory: Link here

• Polish users who performed measurements at ILL, please acknowledge the financing in the publications by 

including the following statement: 

 The authors {name of specific author(s) if necessary} acknowledge(s) the Polish Ministry of 

Education and Science decision no. 2023/WK/08 to fund the scientific membership of Poland at the ILL, which 

made this research possible.

• Cite the use of Mag2Pol as follows:

Mag2Pol: a program for the analysis of spherical neutron polarimetry, flipping ratio and integrated intensity 

data, N. Qureshi, J. Appl. Cryst. 52 (2019) 175-185.

Before you go!

https://neutrons.ornl.gov/powgen/users
https://neutrons.ornl.gov/powgen/users
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084
https://doi.org/10.1107/S1600576718016084


If you have any questions:

Regarding Mag2Pol and need to report bugs.

Contact:

 
Navid Qureshi

Institute Laue Langevin, 

Grenoble, France 

Email: qureshi@ill.fr

Regarding this tutorial, or need a collaborator on 

the lattice and magnetic structure refinement.

Contact: 

Naveen Kumar Chogondahalli Muniraju

Institute of Nuclear Physics, PAN

Krakow, Poland

Email: naveen.chogondahalli@ifj.edu.pl

Good luck with your next refinement project!
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